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Excel 2016 Create Reports 

Two main categories of reports 
Data Dumps 

Try to smoosh as much info as possible onto a page. 

 Narrow margins 

 Adjust column and row width. 

 Format small font size, format numbers to have no decimal places and remove dollar 

signs. 

 Minimize column headers by rotating column headers up to 90 degrees.   

 Can be useful for proof reading each record. Conditional formatting to highlight data 

errors (not covered in this class). Example: set up rules to check if dates fall outside a 

certain range, check for negative numbers, improperly formatted phone numbers, etc. 

 Open the class workbook “Excel Create Reports”, and click on the “Consumer Income” 

tab to see an example of a well-formatted data dump. 

 

Beautiful reports 

Decide format first:  

 Online or printed 

 Color or black and white 

 Physical size – for an iPad, telephone, 8.5” x 11”, or 11” x 17” 

 Stand-alone or as part of a larger report. 

 Click on the “Pretty report” tab 

 

Improve your reports 
Know the reader:  

 Yourself. 

 Teammates familiar with all the data. 

 Executive summary / high level view. 

 

Know the data: 

 Legal limitations.  Example: HCFA privacy laws about revealing patient data 

 Periodicity.  Is this a one-off report, or is it produced every month and something you 

need to maintain?   

 Is this “real” data or “test” data. 

 

Every report should have: 

 Logical design with easy to read layout. 

 Meaningful titles, headers and footers.  If applicable, include page numbers, date 

printed, author name.  

 Colorful graphs, clearly labelled axes.   

 Many companies have standard report layouts and color schemes.  

 Text boxes explaining if data was specially processed.  Ex: double declining vs. straight-

line depreciation, or sales figures including returns. 
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Print preview 
In the bottom right corner of Excel, you’ll see the zoom slider 

bar.  Drag the vertical bar to the left or right to zoom out or 

zoom in. 

 

There are three icons to the left of the zoom; these Workbook Views are also accessible by the 

View Tab.  See http://tinyurl.com/lz5pwqg for even more information: 

Normal: Default view.  Dotted grey lines identify page breaks.   

Page Layout: Displays exactly what would print on each page, including headers and footers, 

images, etc. 

Page Break Preview: The dashed blue line shows page breaks and identifies the page’s 

number.  Very useful for “wide” reports.  Identify “orphan” columns or rows 

disconnected from other pages.  

To Create a Custom view, View > see http://tinyurl.com/m9ltxm8 

 

 

Print a basic report 
(Note: click on ▼ arrows to see more options) 

 

File > Print > click the Print button or <Ctrl p>  - this brings up the Print 

dialog box, home to many important options. 

 

Copies: click on up or down arrows to change the number of copies 

to print. 

Printer select available printer to physically print report, or choose 

PDFCreator to save it as a .pdf file.  You may have other 

choices outside the Library. 

Print Active Sheets this is one way to identify which data is to be 

printed.  See Exercise 1 

Pages when specifying which pages to print, good for testing 

Print One Sided or change to duplex 

Collated   or Uncollated 

Portrait Orientation or Landscape.  See which one fits the number of 

columns best. 

Letter or other physical paper size.  The Copy Center printers also 

print 8 ½” x 14” and 11” x 17”.  B&W for 10 cents, color for 25 

cents. 

Normal Margins or Narrow or Custom.  Some companies have 

formatting standards. 

No Scaling Very powerful tool for fitting big reports on the least 

amount of paper.  The preview on the right side will help you “see” if it is too small. Try Fit 

All Columns on One Page.  

http://www.skokielibrary.info/
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Basic formatting tricks 
Formatting cells can adjust the white space in the report.  Generous white space 

increases readability but can also increase the number of pages. 

 

Select entire column(s) by clicking on the column letter(s). 

Select entire row(s) by clicking on the row number(s). 

<Ctrl a> selects everything. 

 

Reduce white space around cells: Column Width / Row Height – Home > Cells > 

Format.  Click the down arrow.  Now test the options to determine the 

best fit.  I start with AutoFit. 

 

Change cell formatting – right click on the selected cell(s) to get pop-up Format 

Cell dialogue box.   

 Reduce or change font. 

 Rotate the column headers – Home > Alignment tab.  In upper 

right corner, drag the red square up to the 45-degree mark.  Click 

OK. 

 Reduce decimal places – Click Number tab, and under Category click Number.  

Now have Decimal places = 0. 

 

 

Exercise 1 
Open national_m2015.dl.xls, originally downloaded from https://www.bls.gov/oes/tables.htm, I 

used “May 2015”.  This report prints would use 120 pages.  Can this big data dump be printed 

on less paper?   

 

 Using Narrow margins reduces it to using 90 sheets of paper. (Print dialog or Page 

Layout > Page Setup > Margins ▼) 

 Rotating headers 90 degrees and using Auto Width on cols C to T brought it down to 60 

sheets. Check for ### signs which means cells are truncated, make a column wider to 

show the info. 

 Print Landscape and using “Fit all Columns on one page” brings it to 30 sheets of paper. 

 Printing on both sides of the paper finally brings it down to 15 sheets of paper. 

 

Other options: 

 Select and print a subsection of the data.  

o Using the above file, Select A1:G37 

o File > Print 

o Under “Settings”, select Print Selection 

 

 Create a Defined Print Area, each area will print on a separate sheet of paper. 

http://tinyurl.com/ljueaqn for full instructions. 
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Page Setup - Print Column / Row Titles 
If the report is more than one page, repeating the column header helps 

the reader understand the report, especially if a page is read alone. 

Print Layout > Print Titles, and then click on the Sheet tab.  Enter the 

absolute row (or column) reference to print on every page of the report.  

Example: $1:$3 will print the first three rows. 

 

Also, note that in the Page Setup dialog box, you can control printing the 

gridlines, comments and page order. 

 

Headers and Footers 
The easiest way to upgrade a data-dump into a report is to add Headers and Footers (H&F) to 

give context to your report.  As with many Excel options, there are many ways to accomplish 

the same task; this is one way.  Use this with the “Pretty Report” tab. 

Exercise 2 
1. Page Layout tab > Page Setup and click on the little arrow in 

the lower right corner. 

2. In the Page Setup dialog box, click the Header/Footer tab. 

3. In the Header area, click on the “Custom Header” button. 

4. Type in the name of your report in the Center section and press 

OK.   

5. In the Footer area, click on the down arrow on the right hand 

side, the default is (none). 

6. Click on the “Page #” or any other object(s). 

 

 

 

 

 

 

 

 

 

 

Header & Footer Tools > Design tab 

Once you have added a Header or Footer, when you click on either, this tab is available to 

make modifications.   

1. Select the header and the pop-up Format box lets you change the size, font, and color 

of the text. 

2. Add a photo to the right section by clicking on Picture in the Design tab.  It will prompt 

you to find the image on your computer or off the internet. 

3. To change the picture’s size, click on the Format Picture button on the Design tab.  It is 

not possible to center the image up and down, only side to side. 

 

 

Figure 1, Excel lists all the types of objects in the Header & Footer Tools > Design tab 

http://www.skokielibrary.info/
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Watermark 
A watermark is a faint image in the background of a report.  It can be a word, such as 

“DRAFT” or “CONFIDENTIAL”, or it can be an image, like a company logo http://bit.ly/2o03Ryp  

 

Note: using Page Layout > Background will display the image on a screen, but the image will 

NOT print out.  So yeah, kinda useless for our purposes.  

 

Exercise 3 
Use an existing .jpg or .png file for a watermark.   

1. Click on Page Layout and zoom out a bit. 

2. Click anywhere in the Headers & Footers  

3. Click on H&F Tools > Design > Picture. 

4. In the Insert Picture dialog box, click Browse, and then click on the desired image.  In 

class, I included the file Draft.png 

5. Finally, click somewhere outside the H&F area.  This makes the picture visible. 

6. To resize the image, click on H&F Tools > Design > Format Picture. 

7. Experiment with the Scale command, try Height = 125%. 

8. Click on the Picture tab and experiment with shifting the image to the left and down. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Gridlines and miscellaneous things. 
 To print the gridlines, Page Layout > Sheet Options > Gridlines.  Control printing 

and viewing gridlines here. 

 Put a border around Totals or other important data to make it stand 

out.  Home > Font > Borders ▼   

 

 

  

Figure 2 Example of a "Draft" watermark 
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Charts 
The Library teaches a Charts class where you can learn all about how to make and update 

Charts.  For a quick refresher:  http://www.gcflearnfree.org/excel2016/charts/1/ 

 

Good design rules for charts: 

 Use descriptive labels for the axes (the vertical and horizontal “things” that explain what 

the graph is showing. 

 Limit color palette (or black and white) and be consistent with other document 

features. 

 Explain units – are numbers in millions of dollars, or thousands of Euros? 

 

Put an Excel graph in a Word document. 
There are different ways of pasting an Excel graph into a Word 

document, see http://tinyurl.com/lovtwt9 for a thorough explanation of 

the choices.  I recommend copying the Excel graph as a picture and 

inserting it (as a picture) because it is un-editable and unlinked to the 

data or formatting. 

 

Exercise 4 
1. Open the Word Document called “Great Job Scouts”. 

2. Open the Excel class workbook and click on the “Charts good” 

tab. 

3. Select both charts at once by: 

a.  Hold down the <shift> key. 

b.  Click on the “Totals by Scout” graph 

c.  Click on the “Totals by Cookie” graph. 

4. On the leftmost part of the Home tab in the Clipboard area, click on 

the down arrow of the Copy icon (just under the scissors).  Choose 

Copy as Picture.  Finally click on “OK” in the Copy Picture dialog box. 

5. Go back to the Word document, click on where you’d like the chart to be. 

6. On Word’s Home tab, click on Paste.  Note: you could also have clicked on ▼ of Paste 

for more options. 

 

Put a Word document in an Excel graph (not recommended) 
It is possible to insert a Word document into Excel but it’s painful. 

Exercise 5 
1. Click on where you want the item to go. 

2. Insert > Text ▼ > Object 

3. In the Object dialog box, select Microsoft Word Document, and click OK. 

4. Resize the Window by dragging the hold boxes to the desired size. 

5. Start typing in the box.  Notice the ribbon is green, and you are in Word. 

6. Click outside the box and the ribbon is green, and you are in Excel. 

 

 

  

Figure 3 - both charts are selected 
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Text Box 
The easiest way to add text to a spreadsheet is by inserting a textbox.  

Here Excel keeps control over everything, the box can easily be resized, 

and formatting follows regular Excel methods. 

Exercise 5 
1. Insert > Text (on the right side) > Text Box.   

2. Type simple explanatory text.   

3. Text boxes can be moved and resized.  Double click on the box’s 

frame and change its color. 

4. Right-click on a text box’s handle, change its color and weight. 

5. The text box can be resized and moved. 

 

 

Pictures 
Placing a well-chosen photo or company logo can liven up the report, for example including 

a photo of the top-selling item next to its sales report.  This method prints the image exactly 

where inserted.  To automatically print an image on every page, use a Watermark. 

Exercise 6 
1. Insert > Pictures 

2. From the Insert Picture dialog box, browse your computer for the desired image, select 

it, and click Insert.  .PNG and .JPG work the best. 

3. The image can be resized and moved. 

 

 

TOC first tab of a Workbook  
If sharing the entire workbook that contains several tabs, very often making the first tab a table 

of contents with a brief explanation about the data is extremely useful.  Open 

intl_consumer_prices.xl published by the Bureau of Labor Statistics.  See 

https://tinyurl.com/kf3b25n for more details.  For a full explanation of how to insert hyperlinks 

into a workbook, see http://tinyurl.com/kf3b25n 

 

Good design features: 

 Text boxes clearly labeling the report name, which organization compiled the data, the 

published date 

 Contact information 

 Explanation of the methodology 

 Table of Contents with links to the other tabs in the workbook. 

 

Figure 4 - Control formatting 

box by clicking on this 
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