Excel 2016 Get and Transform

Learn more about Excel:

Lynda.com — go to https://skokielibrary.info/resources/online-training-tutorials/ and
click on Lynda.com. Create a free account with your library card number and a
password of your choosing. Enter a search term in the search bar and find an
interesting class.

Goodwill Free Learning — go to https://www.gcflearnfree.org/topics/office2016/ and
scroll to Excel 2016. Basic to intermediate level lessons, especially Pivot Tables

Books

Walkenbach, J. (2018). Excel 2016 Bible. Hoboken, NJ: John Wiley & Sons.

What Get & Transform can do :
Get data : from txt / xlsx / csv files. Tables. Web scraping, including Facebook. SQL
and other databases.

Clean up data: rename columns, delete columns, split columns into multiple smaller
ones, remove null rows, calculate new rows.

Transform data: create pivot tables, unpivot data, de-duplicate data. Merge Queries
can joint two or more files, similar to a VLOOKUP.

Caution: Each version of Get & Transform looks very different in each version of Excel.
What we cover today works at the Library — Excel 2016. Many more features are
available when you add in Power Query and Power Pivot. The most powerful of all is
Power BIl, which works closely with Office 365. When you get help on the internet,
make sure you get release-specific information.

Note: Power Query is known as Get & Transform in Excel 2016. Infarmation provided here applies to both.
To learn more, see Get & Transform in Excel 2016.
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EXERCISE 1 — COPY DATA FROM A WEBSITE, CREATE A .TXT FILE AND TRANSFORM IT INTO AN EXCEL TABLE

1. Open up the Notepad application.  DITIONARY THESAURUS  EXAMPLES

[LlNew Mexico - NM
lew York - NY Ignore the search box, it

2. Open the Excel file called “"GandT 01.xIsx”, and click on the - EEICTERE ot et copied.
first “Start Here" tab.
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3. Click on the hyper link fo . ia- PA

https://abbreviations.yourdictionary.com/articles/state-abbrev.html giiacelsland =R
[WSouth Carolina - SC
[WSouth Dakota - SD

[WTennessee - TN

4. Scroll down to "Alabama — AL", and left-click before that
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state’s name. g -
5. Hold down the shift key and scroll down to the end of the WY | et
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in Wyoming, Left-click again to select all the states. <Ctrl c> g
to copy the data to the PC'’s clipboard.

6. Click in Notepad, <Ctrl v> to paste the data. Each state will get  Foure T copy the dafa

its own cell, such as “Alabama — AL". Save the
file (as .ixt)

Bl &2 -

e Insert Page Layout Formulas, m i
2 (N5 Show Queries |— Connectig H
e & - |
(8| From Table Praperties
Query |

7. In Excel, create a new workbook. cetbeerkl ML s | D | AL | R g
. . i From File . From Workbook Sort & Filter
8. Click on the Data tab > New Query > From File AL T romn o
R rom Database 3 El From CSV G H
> From Text 8 o ~ —
2 == rom Azure » From KM[
3 | D =
4 From Other Sources » From Te
5 | @ DE “‘@
6_ r‘ Combine Queries 13 From Folder
o X 7, ‘g P
ijonmujomnk states.txt @ Imported file's name f;: Dcit:;nou;;ffttingzm
1252: Western Eurapean (Windows) © [E) )
Jasams . Figure 2 Get the data from a .txt file
— 9.1n the Import Data window, select
StateAbbr.ixt (the same file we just
£ pasted the data into). Click the Edit
N button.
@ The data in the preview has been truncated due to size limits @ v
[[oa0 [-] Edit Cancel S KO K | E

Figure 3 Import Data window P U B I_ | C
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10. Welcome to the Power Query Editor! This is where we Transform the data, in this
case we want to split the one column into two. Click on Split Column (by the 1),
and By Delimiter. Click OK.

| @&~ = | GandT 01junk states - Power Query Editor

Home Transform Add Column View
,—)'_j EE'Properties u & =l
e ] =
= = [Z1 Advanced Editor A

Close & Refresh
Load~  Preview ~ [1] Manage =
Close Query
> . ABC Columnl -
E 1 |Alabama - AL
@ 2 |Alaska- AK
(=)
3 |Arizona- AZ
4 | Arkansas - AR
5 |California - CA

1.

Manage Reduce
Columns ~ Rows ™

Sort

O *
i Data Type: Text =
I = g = F
D Use First Row as Headers ~
Split Group 1 Combine Manage Data sou "
Columil~lk By 37 ReplaceValues - Parameters = setting
By Delimiter s— 2 Parameters Data Sou
By Mumber of Characters
Split Column by Delimiter >

Notice the Applied Steps is updated with what you've done. If
you made a mistake, just click on the X before the step. You can

also rearrange the order of steps.

12.

Name" and “State Abbr”.

13.

Rename the columns by double clicking the header. Use “State

Split values in the selected column
based on the specified delimiter.

Name

GandT 01 junk states

All Properties

Query Settings

4 PROPERTIES
Name
StateActr

All Properties

4 APPLIED STEPS
Source
Split Column by Delimiter
Changed Type
X Renamed Columns

Click Close & Load (upper left corner) to get back to the Excel

spreadsheet version of the data. How many rows did you gete

B DA 2 s bodseb

P inser | Page | Forr | Data | Revie | View | Deve | Pows | Desic| Quer| @ Tellme... Marthah.. ]

cel

LI ) A = 9 | [ Conditional Formatting~ i | o
pase 27 Font Alignment Number 7 ez ooz Cells  Editing
LW - - 59 Cell Styles ~ = -
Clipboard Styles
Al 3 £ || state Name
A B C -
1 Workbook Queries
2 |Alabama AL e
3 jAlesks ax O StateAbbr
4 |Arizona AZ
5 |Arkansas AR 50 rows loaded.
6 |california caA
7 |Colorado co
8 |Connecticut T
9 Delaware DE
10 |Florida FL
11 |Georgia GA
12 |Hawaii HI
13 Idaho D
14 Illinois L
15 Indiana IN
16 [lowa 1A
17 |Kansas KS
18 |[Kentucky KY
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“Get & Transform uses queries as its source. Therefore, to use Get & Transform, we need
to create a query. As you move forward and get to know Get & Transform more and
more, the typical way that you'll start a query is from a table or a range.” Oz du Soleil
Lynda.com

EXERCISE 2A — GET & TRANSFORM A FOLDER OF FILES
In the GandT 01 .xIsx file, the Start Here tab, you'll s
find the directions how to get weather information
for a city. To save class time, | put three files in the

| New Refresh Z| Sot  Filter Tedto
ata = Quey=[® | A~ Yo Advanced  Columns 5 T

Data Tools

G It
D FromBile | b From Workbook
A D From Database I:‘rj From CSV s H )

Weather folder. S [t | [y vonmm
1. Create a new Excel file. f [ remonersoes s [ romten
: ‘;’j Combine Queries Ijh‘ From Folder

C.
d.

4.

1
1

1=E

Data > From Query > From file > From folder.
Click the “Browse” button and navigate to
the Weather folder. This window will display
the files in the Weather folder. Click
“Combine & Edit”. Click OK.

[# Data Source Settings. From Folder
Import metadata and links about
fil older.

...........

In the Power Query Editor:

Remove the Station Column (right click the Station
header, and press the delete key or click on
Remove.

Click on the Add Column tab > Custom Column. In
the right column, click on TMAX, then Insert. Type in
a “-"in the formula. Next click on TMIN and then
Insert. If there are no errors, click OK.

Rename the “Custom” header to “Difference”.
Click on Name. Transform > Split Column > by
delimiter > Comma > |left-most delimiter, OK

Home > Close & load.

| have 365 rows of a header and data. You?

Create a custom formula column
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EXERCISE 2B — ADD MORE FILES TO THE FOLDER
BUT WAIT — THERE'S MORE! This is where Get & Transform shows its strength: feach it to clean
up one file and automatically apply the logic to many similar files.

ARl Sl A ey

Select the three folders in the Weather Extra folder, <Ctrl C>(copy).

Open the Weather folder and <Ctrl V> (paste) the files. Close the folder.

Click on the Excel file's Query Tab > Edit.

Click the Refresh > Refresh All once, or twice (depending on the version of Excel)
Click on Close & Load.

Now how many rows do you have?¢

EXERCISE 3 — MERGE QUERIES

Merging two queries is similar fo doing a VLOOKUP — two tables match up by a unique
element and the result is that we can use the data from both tables. In this exercise,
we'll get population by State in one table, and the state’s bird by State. We'll join the
two tables by State, and make one big table.

Note: both tables’ data were pulled from https://simple.wikipedia.org

1.

. Transform > Use First Row as Headers
. Delete columns, keeping only the first three

Open file: Wiki 50 states population birds.xlsx There are two tabs.

2. Click on a cellin the “state info” tab.
3.
4
5

W e -

Data > From Table, which brings up the Query Editor. = -

(abbreviation, state name, capital city) and Established
and Population. Rename the headers as you choose. '
In “St Abbr” (first column), filter out null fields. Click OK.
Select the State Name column (second column).
Transform > Format > Trim to remove leading spaces.

Remove null fields

1 8.Select the Established column (4t col) Data Type > Date
9.Data Type > Year

blishef

e 4 10, Home > Close & Load

uuuuuuuu

ooooooo

uuuuuuuuuuu

BBBBB
uuuuu
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11. Click on the birds tab, and click anywhere on the data.
12.Data > From Table to get to the Query Editor.

13. Delete the Photography and Year columns.

14.Click on the State column, filter out any null fields.
15.Home > Close & Load.

If you are happy with how your “Get"” updates for this exercise went,
continue on with your own file. Else, open the file “Wiki 50 states
population birds with query xIsx” file to continue on to the Merge part of

16. Click on the Sheet 1 tab, then click on a cell it 5 eyttt e e

in the table. 1o Home
B Ftll_‘snmums F (= Connections z*‘l Y

P
om Table =[] Properties

GetExte al | New sl Refresh L7 7| Sert | Filter

Dta  Queny= [ tecentSources ayo [ Fdit Links A

. . U From File »
17.New Query > Combine Queries > Merge I [ e

D E
B established [ population [

Review View

¥

Connections Sort & Filter

@ From Other Sources » | 1819 4574747
Gass 739795
5 Combine Queries  » 5 Merge 016270
004279
6 ICA [ DataSource Settings.. o0 536653
gy fppe d
7 co Query Options 607154
8 T Connecticut Hartford L ha Eaie 588184
1 Launc uel itor
Merge 9 |DE Delaware Dover T4 o 961939
Select tables and matching columns to create a merged table 10]FL Florida Tallahassee | 1845 20984400
11.GA Georeia Atlanta 1788 10429379
List of US_states -
stn [SORR it Gl pomnion Start to Merge!
A Asbama 3 119 s8mar
m Aaska 50 7
w2 Ariona | Phoenix 112 o520
" Arkansas | Lite Rock w6 30027
@ Calfomia | sacramento 1850 39536653

- - 18. Here we identify which 2 tables we want to
. merge, and which fields will be “key”. Click OK.

Campylorhynchus brunneicapillus

Arkansas Northern mockingbird | Mimus palyglottos

19. Click on NewColumn. Transform >
Structured Column > Expand.

Expand NewColumn 20. Deselect (uncheck) State. Click OK. Close & Load.

Select the columns to expand. S KO K | E
m] (Select All Columns)
State
| State bird
| Binomial nomenclature
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EXERCISE 4 — UNPIVOT TABLE

1. Open “Gas Prices from BLS xIsx”. Select all the data in your pivot table. A10:M21

2.
3.

Data > from Table.

4. Transform > Unpivot

5. Home > Close & Load.

mnelson@skokielibrary.info
Linkedin.com/in/martha-nelson

Select all the month columns (don't select Year column).

| @~ < | Tablel - Ouerv Editor
I o
= M
Group Use First Row
By AsHeaders - 5 CountRows

Transform

0 wanspose

Table
» Year ~ | Jan ~ | Feb
; s 2509
w0 2087
© 2011 3415
2012 3.697
s sa
P
w5 2a
ws 1o
2017 2482
w250
w5 20

38 Reverse Rows

ddcolmn  view
Data ype: Decimal Number -
15 Replace vatues

15, Repiace

Any Column

~|Mar  [~[lApr  [~]M.,
2451 2319 2354
239 2008 2081
32607 3827 3075
32804 3.809 3858
3965 3879 3701
4072 3952 383
2364 3019 2755
1023 1047 1989
2474 2449 2438
2856 2827 2875
203 205 3103

Unpivot Columns

3824
3513
3.569
3778
2743
2155
2284
3132
2045

¢
Split  Format

3671

3266
3651
3705
2437
2073
2292
3229

nuil

Xo
)3

Statistics Standard Scientific

~||oat
2553
233
3654
2817
5694
3642
2376
2122
2481
3279

nuil

o x
1g7 dmaomometn - Date o
48 Rounding - Time
Structured
Information ¥ Duration e
Number Column Date & Time Column
oy [Flpee  [-
Query Settings *
2603 279 278
295 5084 3195 4 PROPERTIES
362 3s82 3645 Name
as7  am7  asm
s684 3683 3772 5
5515 338 3138
4 APPLIED STEPS

235 282 2118
2288 225 2398 source

252 2633 279 | ChangedType
5381 3286 2951

nul nul nuil
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